0

I am an administrator in SSAS.

I have many data warehouse servers.

In some servers I have SQL Server and SSAS on the same machine.

I successfully backup the SSAS databases and even check if the backups are healthy

Recently, however, one of our servers which is managed by a third party company based in Canada, needed to be replaced, and while migrating all the ssas databases from the old server to the new one

this is the old server: enter image description here

this is the new server: enter image description here

I am getting this error message while processing the database in the new server:

This command cannot be executed on database 'DWCA' because it has been defined with StorageEngineUsed set to TabularMetadata. For databases in this mode, you must use Tabular APIs to administer the database.

enter image description here

  • Is your SSMS version also same between the 2 Servers ? Have you tried with the exact same version of SSMS in the new server ? – Subbu Sep 22 at 6:50
  • What compatibility level is the actual DB on each server? (Your screenshot only shows the max level the server can run, not the models themselves) I recall getting the same error when we upgraded our models from 1103 to 1200. (MS's move from ASSL to TMSL) – Brandon McClure 3 hours ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.