I know this question has been asked before here and here. But none of them could solve my problem. I have this environment:

  1. Windows 10, build 1903 (freshly installed)
  2. Microsoft SQL Server 2016 (SP2) (KB4052908) - 13.0.5026.0 (X64) Mar 18 2018 09:11:49 Copyright (c) Microsoft Corporation Enterprise Edition (64-bit) on Windows 10 Enterprise 10.0 (Build 18362: )
  3. SSMS v17.3 (14.0.17199.0)

Any activity I want to do in it, from opening, to connecting to a database engine, to right-clicking on a database, to creating a new database, to opening up a new query window, to browsing tables, any activity that is not query takes like 5 to 10 seconds to perform. It's clearly apparent that SSMS is doing something for each activity, and it gets stuck somewhere.

Here are the things I've done so far, without effect:

  1. Blocked Microsoft's certificate URL (adding crl.microsoft.com to hosts file)
  2. Downloading certificate and installing it from http://crl.microsoft.com/pki/crl/products/MicrosoftRootAuthority.crl
  3. Connecting to "local" instead of "."
  4. Resetting user-defined settings in "C:\Users\user\AppData\Roaming\Microsoft\SQL Server Management Studio"
  5. No antivirus is installed (only Windows Defender, the default of Windows)

It's a shame that a program from such a reputable company can't work smooth out of the box, and troubleshooting it is very difficult.

How can I diagnose what's wrong with SSMS?

Update: This problem exists even with SSMS v18.2 (15.0.18142.0)

  • What type of disk system is everything on? Once I went from spinning to solid state SSMS, and everything else for that matter, really woke up.
    – nkdbajoe
    Commented Sep 21, 2019 at 11:34
  • It's SSD. And I've tested SSMS on this machine many times. The same version. In fact, we have a checklist of how to setup a fresh development machine installation. Commented Sep 21, 2019 at 12:09
  • 1
    Can you try another version of SSMS? I am running 17.9 right now and I am seeing <= 5 seconds for the tasks you listed.
    – nkdbajoe
    Commented Sep 21, 2019 at 12:13
  • Can they be installed side-by-side? Or should I upgrade? I mean, we have a strict policy of what should be installed on our machines, for a lot of QA/QC reasons. And, regardless of a new version, how can I diagnose the problem in this version? Commented Sep 21, 2019 at 12:53
  • You can try Process Monitor for diagnose (learn.microsoft.com/en-us/sysinternals/downloads/procmon). You have to set up a filter to catch only SSMS related stuff. This can be a good starting point for such problems. Commented Apr 23, 2020 at 5:25

4 Answers 4


I also had the mystery slow down in v14 and then upgraded to 18.5 Post upgrade 18.5 worked fast...a few days (and reboots) later it bogged down again. Network trace showed a ton of IP6 traffic which we have not configured but somehow became a default 'on' in Windows 10.

Disabled Ip6 on the ethernet adapter and all working fine now.

  • This doesn't make any sense, but this did in fact solve my issue
    – Coruscate5
    Commented May 2, 2022 at 22:56

I found this solution. It worked for me every time:

  1. Open C:\Windows\System32\drivers\etc\hosts with Notepad
  2. Add this line to it SomeNameHere
  3. Save (make sure it's saved by reopening it)
  4. Now connect to SQL Server Management Studio, using SomeNameHere

I've tried all suggestions with no result until now:-

Try setting the RAM manually in MS SQL Server Management Studio -> Right Click the SQL Server in Object Explorer -> Properties -> Memory. I set my min memory to 1000 MB and the max to 2000 MB and saw an immediate improvement. (The max by default was set to something silly like 2147483647 MB. Isn't that over 2 million Gig!!!!!).

(Should be a simple fix for Microsoft to achieve).

  • No, this is bad advice. This is the memory for the SQL Server instance not SQL Studio app. There is a reason the max ram for SQL Server is set so high, dont mess with it unless you know what youre doing
    – userSteve
    Commented Jun 23, 2023 at 15:02

SSMS was way too slow after I changed the RAM in my PC. I feared that was the cause. Before following up answers here decided to reboot. That was enough to fix it for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.