0

I just started learning how to use Cassandra, but at the moment I am trying to troubleshoot a small problem with GCE and Cassandra. I am not able to connect to it at all.

I am using this Deployment from the Google Marketplace.

I have tried:

  • Allowing all ingress traffic

Connecting to it with the NodeJS driver or another GCE instance does not work. I do not think that the firewall has something to do with it, since 1. the Deployment does set up some firewall rules, and 2. I did allow all ingress traffic for testing.

Any ideas for what could be going horribly wrong here?

NodeJS Driver:

NoHostAvailableError: All host(s) tried for query failed. First host tried, x.x.x.x:9042: DriverError: Connection timeout.

Using CQLSH from another GCE instance:

Connection error: ('Unable to connect to any servers', {'x.x.x.x': error(None, "Tried connecting to [('x.x.x.x', 9042)]. Last error: timed out")})

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.