2

I have updated my SQL Server 2016 on one of my Windows Failover Cluster nodes successfully. When I attempted to failover one of my SQL instances onto the newly patched node, SQL Server service fails to come online. These are the errors that I'm seeing:

Error: 3930, Severity: 16, State: 1. The current transaction cannot be committed and cannot support operations that write to the log file. Roll back the transaction.

Error: 912, Severity: 21, State: 2. Script level upgrade for database 'master' failed because upgrade step 'msdb110_upgrade.sql' encountered error 3930, state 1, severity 16. This is a serious error condition which might interfere with regular operation and the database will be taken offline. If the error happened during upgrade of the 'master' database, it will prevent the entire SQL Server instance from starting. Examine the previous errorlog entries for errors, take the appropriate corrective actions and re-start the database so that the script upgrade steps run to completion.

Error: 3417, Severity: 21, State: 3. Cannot recover the master database. SQL Server is unable to run. Restore master from a full backup, repair it, or rebuild it. For more information about how to rebuild the master database, see SQL Server Books Online.

I'm also seeing some Failed to verify the Authenticode signature... messages.

The only way I was able to successfully failover the SQL instance was by adding Trace Flag 902. I ran the msdb110_upgrade.sql script and it ran fine (although it did take 3 minutes). This is the result:

TSQL Transact-SQL Subsystem [Internal] [Internal] [Internal] [Internal] [Internal] 480 1 CmdExec Command-Line Subsystem SQLCMDSS.DLL NULL CmdExecStart CmdEvent CmdExecStop 240 3 Snapshot Replication Snapshot Subsystem SQLREPSS.DLL C:\Program Files\Microsoft SQL Server\130\COM\SNAPSHOT.EXE ReplStart ReplEvent ReplStop 2400 4 LogReader Replication Transaction-Log Reader Subsystem SQLREPSS.DLL C:\Program Files\Microsoft SQL Server\130\COM\logread.exe ReplStart ReplEvent ReplStop 600 5 Distribution Replication Distribution Subsystem SQLREPSS.DLL C:\Program Files\Microsoft SQL Server\130\COM\DISTRIB.EXE ReplStart ReplEvent ReplStop 2400 6 Merge Replication Merge Subsystem SQLREPSS.DLL C:\Program Files\Microsoft SQL Server\130\COM\REPLMERG.EXE ReplStart ReplEvent ReplStop 2400 7 QueueReader Replication Transaction Queue Reader Subsystem SQLREPSS.dll C:\Program Files\Microsoft SQL Server\130\COM\qrdrsvc.exe ReplStart ReplEvent ReplStop 2400 8 ANALYSISQUERY Analysis query subsystem SQLOLAPSS.DLL NULL OlapStart OlapQueryEvent OlapStop 2400 9 ANALYSISCOMMAND Analysis command subsystem SQLOLAPSS.DLL NULL OlapStart OlapCommandEvent OlapStop 2400 10 SSIS SSIS package execution subsystem SQLDTSSS.DLL C:\Program Files\Microsoft SQL Server\130\DTS\Binn\DTExec.exe DtsStart DtsEvent DtsStop 2400 11 PowerShell PowerShell Subsystem SQLPOWERSHELLSS.DLL C:\Program Files (x86)\Microsoft SQL Server\130\Tools\Binn\SQLPS.exe PowerShellStart PowerShellEvent PowerShellStop 2 12

Each time, I would NET STOP the SQL service and NET START without Trace Flag 902, but the SQL service would still fail.

Has anyone run into this and found a solution?

Edit 1: I was able to successfully fail over another SQL instance on to the recently patched node. It's absolutely baffling why this one particular SQL instance isn't coming online with T902. I did notice another thing. I see a Failed to update database "DB" because the database is read-only and Error executing sp_vupgrade_replication

Edit 2: I was originally on version 13.0.5337.0 and updated to 13.0.5479.

Edit 3: I was just informed that Microsoft issued a warning for this CU9 (however, I don't believe this is causing the issue I'm facing): Important There is an uninstall issue with SQL16 SP2 CU9. The payload in CU9 is fine, but if you have not already installed CU9, it is recommended that you wait for the upcoming expedited SQL16 SP2 CU10 release.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.