0

I'm trying to backup databases through SSMS and cannot see any already-mapped network drives.

The SQL Server service account is what I'm using to log in, and it has permissions to the network share, which is already automatically mapped, no matter where on the network I log in from.

I've tried turning on XP_CMDSHELL and doing the net use thing, but the drive is already mapped, so it blows off.

I tried a registry hack, adding EnableLinkedConnections in the proper place, but that also hasn't worked.

Any ideas where I should look next?

  • Possible duplicate of Backup SQL Server To NAS – Tony Hinkle Oct 7 at 19:23
  • I read that question, and not only did that stuff not work, my SQL Servers are running their services under a separate network account that does have the permission to log on interactively. Further, if I drop to the OS, the mapped network drive is seen. SQL Server just can't see it. – J.D. Walker Oct 7 at 19:29
  • JD--highly recommend that you use the UNC path instead of a mapped drive. There are just more possible problems with the mapped drive than with the UNC path. Essentially, there is no good reason to use a mapped drive, and it adds complexity and more risk of failure. If the code that maps the drive fails due to a network issue that is occurring at the time it runs, then you're backups will fail. – Tony Hinkle Oct 7 at 19:45
  • I don't have an issue doing that, but that also does not work Having said that, my chief system administrator created that network share with a space in the name, so I am waiting until the rename takes the space out to see if that will help. – J.D. Walker Oct 7 at 19:47
  • and taking the space out worked, thank you. – J.D. Walker Oct 9 at 12:58
0

Mapped network drives are mapped per-user, during user log on. Services don't typically logon interactively. You won't be able to use mapped network drives with SQL Server without jumping through quite a few hoops: https://stackoverflow.com/questions/182750/map-a-network-drive-to-be-used-by-a-service

You'll probably need to use UNC paths...

HTH.

  • The user under which the SQL Server service runs is the same user that has access to the mapped network drive, and IS able to log on interactively. I'm tearing my hair out here (what little I have) because everything I'm finding under Google simply does not work – J.D. Walker Oct 7 at 19:15
  • Oh, and not my doing, but the UNC path has a space in it. Could that be why it does not work? – J.D. Walker Oct 7 at 19:57
  • The fact that the service has the log on privilege, doesn't mean it logs on - SQL Server doesn't and has no need to. For UNC paths with spaces in them, you need to use double quotes delimiting the full path string. – SQLRaptor Oct 7 at 21:22
  • Taking out the space worked. Thanks everyone. – J.D. Walker Oct 9 at 12:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.