0

I have recently installed sql server 2014 enterprise version on windows 2016 server. For some reason sql server agent is not starting but sql server service is up and running. I am not really sure what is happening. From the sql server agent log file , I could see below information. Do you think I should repair the sql server ? I have read else where it might be due to sql server native client installation problem ? Also, in the event log I noticed the permission related issue. I did some research and I tried to provide proper permissions to that APPID and CLSID but still I could not bring that sql agent up. Thanks

========================================================

             2019-10-09 00:54:15 - ? [100] Microsoft SQLServerAgent 
           version 
           12.0.6024.0 (X64 unicode retail build) : Process ID 55496
           2019-10-09 00:54:15 - ? [495] The SQL Server Agent startup 
           service account is WORKGROUP\D03XXX
           2019-10-09 00:54:15 - ! [150] SQL Server does not accept the 
           connection 
          (error: 0). Waiting for Sql Server to allow connections. 
          Operation attempted was: Verify Connection On Start.
           2019-10-09 00:54:15 - ! [000] Unable to connect to server.    
            '(local)';     SQLServerAgent cannot start
          2019-10-09 00:54:15 - ! [298] SQLServer Error: 27, Registry 
           information is corrupt or missing. Make sure the provider is 
           installed and  registered correctly. [SQLSTATE 08001] 
           2019-10-09 00:54:15 - ! [298] SQLServer Error: 27, Client
           unable  to establish connection [SQLSTATE 08001] 
           2019-10-09 00:54:15 - ! [165] ODBC Error: 0, A network- 
            related or instance-specific error has occurred while.    
            establishing a connection to SQL Server. Server is not found 
             or not accessible.           
             Check if instance name is correct and if SQL Server is.   
            configured to allow remote connections. 

           For more information see SQL Server Books Online. 
           [SQLSTATE. 08001] 
           2019-10-09 00:54:15 - ! [382] Logon to server '(local)' failed 
           (DisableAgentXPs)
          2019-10-09 00:54:15 - ? [098] SQLServerAgent terminated
           (normally)

========================================================

      EVENT LOG snippet 

    The application-specific permission settings do not grant Local. 
     Activation permission for the COM Server application with CLSID 
     {D63B10C5-BB46-4990-A94F-E40B9D520160}
      and APPID {9CA88EE3-ACB7-47C8-AFC4-AB702511C276}
     to the user NT SERVICE\SQLSERVERAGENT SID (S-1-5-80- 
      344959196-2060754871- 
       2302487193-2804545603-1466107430) from address.     
      LocalHost (Using LRPC) 
      running in the application container Unavailable SID 
       (Unavailable). This security permission can be modified using 
      the Component Services administrative tool.
  • Do you have default or named instance? >>>Unable to connect to server. '(local)'<<< – sepupic Oct 9 '19 at 6:55
  • Sorry I did not understand? I used default instance while installing – data_weed Oct 9 '19 at 7:02
  • Ok for default instance. As the error said "Check if instance name is correct" I just wanted the confirm that 'local' is the correct server name. – sepupic Oct 9 '19 at 7:04
  • The error you've find in event log is strange as it says about virtual account NT SERVICE\SQLSERVERAGENT but your agent runs under WORKGROUP\D03XXX – sepupic Oct 9 '19 at 7:06
  • @sepupic, i tested created a new user with administrator group and tried starting the sql agent using that account through sql configuration manager. But still it failed. I even tried with local system in built account – data_weed Oct 9 '19 at 7:13
1

I have re-installed the sql server 2014 and it fixed this issue. I have realized the sql server native client was not properly installed. Thanks your time

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.