0

I am trying to solve a Replication issue here in MongoDB 4.2, but I can no longer get my Primary server back to primary, it always stays in SECONDARY mode. I've tried several types of solutions, like this Or here

But without success.

In the logs, I came across these messages:

 Scheduling remote command request for vote request: RemoteCommand 729 -- target:mongo2:27021 db:admin cmd:{ replSetRequestVotes: 1, setName: "MyReplicaSet", dryRun: true, term: 2, candidateIndex: 0, configVersion: 125668, lastCommittedOp: { ts: Timestamp(1570799675, 1), t: 2 } }
 2019-10-11T11:17:25.041-0300 I  ELECTION [replexec-2] VoteRequester(term 2 dry run) received an invalid response from mongo2:27021: NotYetInitialized: no replset config has been received; response message: { operationTime: Timestamp(0, 0), ok: 0.0, errmsg: "no replset config has been received", code: 94, codeName: "NotYetInitialized", $clusterTime: { clusterTime: Timestamp(1570799675, 1), signature: { hash: BinData(0, 0000000000000000000000000000000000000000), keyId: 0 } } }
 2019-10-11T11:17:25.041-0300 I  ELECTION [replexec-2] not running for primary, we received insufficient votes
 2019-10-11T11:17:25.041-0300 I  ELECTION [replexec-2] Lost dry run election due to internal error

How to fix this? Possible a bug? I have tried 4.0.12 and It is work fine

  • 1
    How many members do you have in your replica set? – Marcos Zolnowski Oct 11 at 21:24
  • 1
    just one, I belive it is a bug. I make a downgrade for 4.0.12 and it is run fine! – Vitor Mazuco Oct 14 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.