1

I am connecting to the DB2 database using oracle SQL developer, but automatically it is committing, i checked in the advanced menu the auto commit feature is turned off. I am confused now, can someone help me in switching off auto commit.

1

Check whether auto-commit is really off (or if it's a glitch in the gui), by (for example):

1. create table T (x int);
2. rollback;
3. select * from t;   -- should result in an error
  • No error in selecting data – nikhilgupta86 Oct 28 at 14:33
  • Then autocommit is on regardless of what the gui says – Lennart Oct 28 at 15:24
  • What happens if you enable auto-commit, and then disable it again? – Lennart Oct 28 at 19:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.