1

We have an old Oracle 12c database server that is not up to date (version 12.1.0.1.0). Unforunately a full version upgrade is out of scope right now, but I was hoping to at least apply the latest patch bundle we have on hand, which would take us to 12.1.0.1.160719 and fix a few vulnerabilities.

I used OPatch and got everything applied without incident, but when I tried to run the datapatch utility afterward I recieved the following errors:

SQL Patching tool version 12.1.0.1.0 on Thu Oct 17 12:10:58 2019
Copyright (c) 2014, Oracle.  All rights reserved.

Connecting to database...OK
Determining current state...
Currently installed SQL Patches:
Currently installed C Patches: 23530410
Adding patches to installation queue and performing prereq checks...
Installation queue:
  Nothing to roll back
  The following patches will be applied: 23530410
catconInit: database is not open
Installing patches...
Patch installation complete.  Total patches installed: 1
Validating logfiles...
Patch 23530410 apply:
  logfile:  (no errors)

See support note 1609718.1 for information on how to resolve the above errors

SQL Patching tool complete on Thu Oct 17 12:11:41 2019
catconExec: catconInit has not been runcatconWrapUp: catconInit has not been run

I've found similar errors on Google about 'catconInit: database is not open on the default instance' but nothing that is exactly the same message as mine. In fact, when I Google the last error message 'catconExec: catconInit has not been runcatconWrapUp: catconInit has not been run' I only get one result--the Oracle Support page for this error (Doc ID 1609718.1). Unfortunately, we do not have an ongoing support contract and I cannot see the cause/solution for this.

Also:

  • There is only one database/instance on this server, and I specify that with the datapatch parameter
  • The database is open per V$INSTANCE, and both myself and the application can query it just fine
  • I've been a DBA for a few years now, but I'm new to Oracle specifically

Does anyone have any ideas? Can anyone relay the information from the support doc? Thanks in advance.


EDIT

  • OS is Windows Server 2012 R2 Standard

  • Rerun of 'datapatch -verbose -db MyDatabase' produces the exact same output (just with newer timestamps)

  • The associated log file from the most recent run of datapatch (D:\oracle\MyDatabase\cfgtoollogs\opatch\opatch2019-11-05_13-29-08PM_1):

patch log

  • Try to run datapatch -verbose again and post complete output along with log file(log file generated in $ORACLE_HOME/cfgtlogs/sqlpatch/sqlpatch_xxx/sqlpatch_invocation,log) .What O/s and edition?/ – Kumar Nov 5 at 17:51
  • Thanks for the response. I reran datapatch -verbose -db MyDatabase and got the exact same output just with newer timestamps. I found the associated log file (slightly different path, $ORACLE_HOME\cfgtoollogs\opatch) and added a screenshot to the original post. Lastly, this is on Windows Server 2012 R2 Standard. – NewOracleDBA Nov 5 at 18:45
  • I'm not sure about Winodows server but thats opatch logfile not datapatch e.g on my Oel 7 this is the location of logfile generated by datapatch is/u01/app/oracle/12.2/db_1/cfgtoollogs/sqlpatch/sqlpatch_3096_2019_11_05_12_06_52/sqlpatch_invocation.log. Start elevated command prompt ,set correct environment and run datapatch -verbose byw is it RAC and Prod server. – Kumar Nov 5 at 20:05
  • Yeah I noticed it was for opatch too, but it was still generated when I ran 'datapatch -verbose' as administrator and I don't see any datapatch specific files or folders. I'll do some more digging and see if I can find anything else. And no, this is not a RAC environment and it is not Prod, just a Test server. – NewOracleDBA Nov 5 at 21:06
  • 1
    Try to startup database in upgrade mode 1 ) shutdown immediate 2)startup upgrade 3) datapatch -verbose – Kumar Nov 5 at 21:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.