0

Installing SQL Server 2017 Standard on Windows 2016 and hitting errors when entering the new service accounts for SQL agent, service, SSIS.

'The RPC Service is unavailable, Click retry the failed action'

At the bottom of the installer page it complains that the user accounts are invalid. I know the AD accounts work and can log into the windows server as the service accounts.

My network admin forced me to enable WINS on this server and it now works, does anyone know why or what could be being blocked as the server is behind a firewall but the local firewalls are turned off.

1

Looks like we have located the issue, DNS entry for the domain is wrong which is being pushed out via group policy.

Thanks to Pinal Dave for his blog post

https://blog.sqlauthority.com/2018/07/21/sql-server-install-error-validation-for-setting-agtsvcaccount-failed-error-message-the-rpc-server-is-unavailable/

Just in case the link becomes stale:

Against the properties of the Ethernet adapter, IPV4, DNS tab, in the section for 'Append these DNS Suffixes' we have an incorrect entry for domain, this is controlled by group policy (for us) we are resolving this now.

  • 1
    Stockburn, since links can change or become dead over time, its best to add the relevant information to an answer itself. Can you provide some more info on what the actual solution was? – LowlyDBA Nov 7 at 22:02
  • Good point mate, I have dropped some more info into the answer – Stockburn Nov 8 at 1:34
  • Just wanted to confirm that we have removed the incorrect DNS domain information and we no longer need to WINS as a work around. – Stockburn Nov 11 at 3:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.