2

I've recently begun receiving alerts like this one:

Always On Availability Groups transport has detected a missing log block for availability database "myDb". LSN of last applied log block is (xxxx:xxxxxxx:x). Log scan will be restarted to fix the issue. This is an informational message only. No user action is required.

According to this article, it should have been fixed in SQL Server 2016 SP2 CU 2. My environment is SQL Server 2016 SP2 CU7, so I don't understand why I'm seeing this. Anyone here knows what could be causing it or if anything is actionable, aside from opening an MS support ticket?

  • If there are no other clues, you'll probably need to open a support incident with Microsoft to get this diagnosed. I searched my recent logs and there are a few instances of this message, but it is always right after the database is joined to the AG (after SQL Server restart) or after a disconnect/reconnect. I think this message is expected in those cases--i.e., it is simply an informational, as it states, and does not mean there is a problem. – Tony Hinkle Nov 8 at 15:04
  • ...and there may have been a defect that caused this condition to occur unexpectedly, but that doesn't mean that the associated fix changed anything for the expected occurrences. Check your logs to see what was happening right before/during when these messages were logged. – Tony Hinkle Nov 8 at 15:07
  • Well... the only thing going on was a (successful) CHECKDB, though I don't see how it could cause this message to pop up. I'll keep digging but I think I'll have to open a support case. – GabSql yesterday

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.