3

I had the following settings in /etc/sysctl.conf before Catalina:

# PostgreSQL Config for the MAC
kern.sysv.shmmax=2147483648
kern.sysv.shmall=524288
kern.sysv.shmmin=1
kern.sysv.shmmni=32
kern.sysv.shmseg=8
kern.maxprocperuid=1024
kern.maxproc=2048

The Catalina install moved this file to the /Users/Shared folder as /etc is now considered private to macOS.

Are these settings still relevant for Catalina, and if so, where do they need to go?

Thx.

1
  • 1
    Are you planning to run scalability tests or production workloads on your Mac? If not, you might as well just leave kernel parameters alone.
    – mustaccio
    Commented Nov 8, 2019 at 19:49

2 Answers 2

0

You don't need the shared memory parameters any more, because PostgreSQL has been using POSIX shared memory for a while now.

Making sure that the PostgreSQL user can have enough open files is a good idea though.

0

I ran into the same issue. I put the file back (at /etc/sysctl.conf) and it worked just like before (at least for setting kern.maxvnodes).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.