1

Last night MySQL Service on my XAMPP local server was running fine. Today... it starts for 10 seconds and then give me following error:

10:14:28 AM  [main]     Initializing Modules
10:14:28 AM  [main]     The FileZilla module is disabled
10:14:28 AM  [main]     The Mercury module is disabled
10:14:28 AM  [main]     Starting Check-Timer
10:14:28 AM  [main]     Control Panel Ready
10:14:31 AM  [Apache]   Attempting to start Apache app...
10:14:31 AM  [Apache]   Status change detected: running
10:14:38 AM  [mysql]    Attempting to start MySQL app...
10:14:38 AM  [mysql]    Status change detected: running
10:14:49 AM  [mysql]    Status change detected: stopped
10:14:49 AM  [mysql]    Error: MySQL shutdown unexpectedly.
10:14:49 AM  [mysql]    This may be due to a blocked port, missing dependencies, 
10:14:49 AM  [mysql]    improper privileges, a crash, or a shutdown by another method.
10:14:49 AM  [mysql]    Press the Logs button to view error logs and check
10:14:49 AM  [mysql]    the Windows Event Viewer for more clues
10:14:49 AM  [mysql]    If you need more help, copy and post this
10:14:49 AM  [mysql]    entire log window on the forums

The Log file follows:

2019-11-21 10:14:38 0 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2019-11-21 10:14:38 0 [Note] InnoDB: Uses event mutexes
2019-11-21 10:14:38 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
2019-11-21 10:14:38 0 [Note] InnoDB: Number of pools: 1
2019-11-21 10:14:38 0 [Note] InnoDB: Using SSE2 crc32 instructions
2019-11-21 10:14:38 0 [Note] InnoDB: Initializing buffer pool, total size = 16M, instances = 1, chunk size = 16M
2019-11-21 10:14:38 0 [Note] InnoDB: Completed initialization of buffer pool
2019-11-21 10:14:38 0 [Note] InnoDB: 128 out of 128 rollback segments are active.
2019-11-21 10:14:38 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2019-11-21 10:14:38 0 [Note] InnoDB: Setting file '\CoreApps\Mayfield\xampp-rtweek\mysql\data\ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
2019-11-21 10:14:38 0 [Note] InnoDB: File '\CoreApps\Mayfield\xampp-rtweek\mysql\data\ibtmp1' size is now 12 MB.
2019-11-21 10:14:38 0 [Note] InnoDB: Waiting for purge to start
2019-11-21 10:14:38 0 [Note] InnoDB: 10.3.15 started; log sequence number 1604056; transaction id 9
2019-11-21 10:14:38 0 [Note] InnoDB: Loading buffer pool(s) from E:\CoreApps\Mayfield\xampp-rtweek\mysql\data\ib_buffer_pool
2019-11-21 10:14:38 0 [Note] InnoDB: Buffer pool(s) load completed at 191121 10:14:38
2019-11-21 10:14:38 0 [Note] Plugin 'FEEDBACK' is disabled.
2019-11-21 10:14:38 0 [Note] Server socket created on IP: '::'.

Apparently, there doesn't seem to be any error. I have an older version of XAMPP that is workin' fine, which means there is no Port 3306 issue.

I have tried couple of suggested solutions on other platforms, e.g. deleting ib_logfile0, ib_logfile1, and ibdata1 files and adding

innodb_force_recovery = 4

to configuration file, that didn't work for me.

What could be the issue here?

-2

first suspect .. the usual - "windows happened" - Wednesday = patchday - there is potential risk that one of the updates "f**ked" things up - and in most cases a simple reboot should do it.

But if you tried with a second mysql server ... make sure that the port is free when you try to start this one the next time.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.