4

I have a Integration Services project within SSDT that has multiple packages. When I right click a single package and choose deploy, SSDT says the operation completed successfully.

However, when I look at the internal.packages table within SSISDB on the target server, it does not contain the latest version that I just deployed. Neither the version_build field or the version_guid field match the values within my package. The SSIS Catalog also displays the incorrect information.

enter image description here

enter image description here

It looks to me as though it is not deploying the package at all - except the internal.projects table is clearly getting updated with a new time stamp on each deployment, and the internal.packages table adds a new row as well.

So, my question is - why is the package not getting updated?

  • Do you have the ability to open it up in Visual Studios and run a demo? What are the results there? Has it ever worked or did it stop working at a certain point in time? – Muab Nhoj Nov 25 '19 at 15:28
  • If I run the package within SSDT/Visual Studio it runs fine. If I run the deployed version it is definitely running the old implementation. – World Wide DBA Nov 25 '19 at 16:07
  • Hi @Mr.Brownstone, (same question I've made to @SteveG): On the project properties, is the "TargetServerVersion" set to SQL Server 2017? (Package deployment is supported only from SQL Server 2016 - and the way it behaves depends on "TargetServerVersion") – Evandro Feb 18 at 15:52
  • @EvandroMuchinski SQL Server 2017 (Enterprise Edition) – World Wide DBA Feb 18 at 21:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.