0

I am using Master Slave replication for master and slave . Master Configuration 64 GB RAM 2 TB SSD

Slave Configuration :

16 GB RAM 2 TB SSD

My database size is 750 GB.

When i configured replication it was working fine in the starting but after few hours it is showing the the following error and executed master position stucked at that point .

Connect_Retry: 60
          Master_Log_File: binlog.000021
      Read_Master_Log_Pos: 751503670
           Relay_Log_File: logfi-bin.000007
            Relay_Log_Pos: 330951766
    Relay_Master_Log_File: binlog.000021
         Slave_IO_Running: Yes
        Slave_SQL_Running: Yes
          Replicate_Do_DB:
      Replicate_Ignore_DB:
       Replicate_Do_Table:
   Replicate_Ignore_Table:
  Replicate_Wild_Do_Table:
  Replicate_Wild_Ignore_Table:
               Last_Errno: 0
               Last_Error:
             Skip_Counter: 0
      Exec_Master_Log_Pos: 330951598
          Relay_Log_Space: 751520239
          Until_Condition: None
           Until_Log_File:
            Until_Log_Pos: 0
       Master_SSL_Allowed: No
       Master_SSL_CA_File:
       Master_SSL_CA_Path:
          Master_SSL_Cert:
        Master_SSL_Cipher:
           Master_SSL_Key:
    Seconds_Behind_Master: 168711
 Master_SSL_Verify_Server_Cert: No
            Last_IO_Errno: 0
            Last_IO_Error:
           Last_SQL_Errno: 0
           Last_SQL_Error:
Replicate_Ignore_Server_Ids:
         Master_Server_Id: 1
              Master_UUID: 0163faf8-d88b-11e9-941a-0894ef352522
         Master_Info_File: mysql.slave_master_info
                SQL_Delay: 0
      SQL_Remaining_Delay: NULL
  Slave_SQL_Running_State: Applying batch of row changes (delete)
       Master_Retry_Count: 86400
              Master_Bind:
  Last_IO_Error_Timestamp:
 Last_SQL_Error_Timestamp:
           Master_SSL_Crl:
       Master_SSL_Crlpath:
       Retrieved_Gtid_Set:
        Executed_Gtid_Set: 0163faf8-d88b-11e9-941a-0894ef352522:1-625929
            Auto_Position: 0
     Replicate_Rewrite_DB:
             Channel_Name:
       Master_TLS_Version:
   Master_public_key_path:
    Get_master_public_key: 0
        Network_Namespace:

I have run

SET GLOBAL SQL_SLAVE_SKIP_COUNTER = 1;

but its not working anymore . also i have done

sync_binlog=0

can you suggest which parameter need to change.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.