0

I'm getting the following error at the very end of SQL Server 2016 setup.

Updating permission setting for file 'Local Machine' failed. Principal 'SYSTEM\CurrentControlSet\Services\Eventlog\Appliaction\DatabaseMail' was tried to be added to the file permission setting. The file permission setting was supposed to be set to 'account name'.

It seems like a permissions issue. Any help would be greatly appreciated. Thanks

1

Thanks for the help. I found out it was a HIPS (Host Intrusion Protection System) blocking the registry entries. Once I disabled it, the installation completed successfully. Thanks again.

  • Good deal. I hate HIPS. – MelvinLusk Dec 13 '19 at 15:42
0

Whatever account you're using to install SQL doesn't have permissions to modify the registry and the file system. You should run the installer using an account that has local administrative access.

  • Thanks for your response. My account does have local administrative access but still getting the error. Thanks. – JAY Dec 12 '19 at 17:31
  • Weird. How about the account that you specified for running the service? – MelvinLusk Dec 12 '19 at 17:32
  • Yeah. It looks like it's trying to use the default NT Service account for SQL Service to write to the registry instead of the managed service account I'm using for the SQL Service. – JAY Dec 12 '19 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.