1

I am unable to add a replica to the cluster.

Steps tried:

  • done hot backup for existing member.
  • Copied it to new replica.
  • Tried to start the server, it's failing with these errors:
2019-12-31T13:03:38.277+0000 E STORAGE  [initandlisten] WiredTiger error (0) [1577797418:277479][8130:0x7ff6a95f9b80], connection: __wt_cache_destroy, 358: cache server: exiting with 169 bytes in memory Raw: [1577797418:277479][8130:0x7ff6a95f9b80], connection: __wt_cache_destroy, 358: cache server: exiting with 169 bytes in memory
2019-12-31T13:03:38.279+0000 W STORAGE  [initandlisten] Failed to start up WiredTiger under any compatibility version.
2019-12-31T13:03:38.279+0000 F -        [initandlisten] Fatal Assertion 28559 at src/mongo/db/storage/wiredtiger/wiredtiger_util.cpp 65
2019-12-31T13:03:38.279+0000 F -        [initandlisten] aborting after fassert() failure

We are using percona mongodb - 4.0.13-7

What could be the reason?

  • 1
    Looks like that your "hot backup" was not successful or done wrong way, because wiretiger complains about datafile -version. Did you do file system level snapshot of database directory? (because all files at the directory must be "copied" at exact same moment of time) – JJussi Jan 1 at 13:09
-1

If you add a new replica node, Mongodb will itself copy the data across to the new node. Unless if your data size is huge and do not want your network to be flooded in transferring the data you can follow the backup method.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.