We change the PowerShell subsystem max_worker threads to 10, but after we install the latest cumulative update, it reverts back to 2. Is there a way to keep that from happening?

SELECT  s.subsystem_id, 
        m.[text] AS [description], 
FROM msdb.dbo.syssubsystems s
INNER JOIN msdb.sys.messages m ON s.description_id = m.message_id 
AND m.language_id = 1033

1 Answer 1


Create an agent job that runs on start up to set the number of threads. Set the schedule option to Start Automatically when SQL server agent starts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.