0

I was trying to upgrade mongo 3.4.20 to 4.0.14 , but it lead to the system crash, so i tried reverting it back to 3.4.20. But after doing db restart using fork , there 502 error. Please help.I tried the following command sudo mongod --fork --auth --logpath /var/log/mongodb/mongod.log

  • So, have you tried looking in /var/log/mongodb/mongod.log? – mustaccio Jan 16 at 19:16
  • Hey @mustaccio , thank you for the suggestion, yes , i did, and finally i got it resolved just now by running the fork command along with auth command in following manner : sudo mongod --fork --auth --port 27017 --dbpath /var/lib/mongodb --logpath /var/lib/mongodb/mongod.log – ramiya dash Jan 16 at 19:23
0

I could finally get it to work by executing following command :

sudo mongod --fork --auth --port 27017 --dbpath /var/lib/mongodb --logpath /var/lib/mongodb/mongod.log

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.