1

How can i resolve this issue below?

use eNtsaMemberRegistrationDB
go
grant all on tablename to Users;

Message

The ALL permission is deprecated and maintained only for compatibility. It DOES NOT imply ALL permissions defined on the entity.

3

Always best to check the documentation.

GRANT

This option (ALL) is deprecated and maintained only for backward compatibility. It does not grant all possible permissions. Granting ALL is equivalent to granting the following permissions:

If the securable is a table, ALL means DELETE, INSERT, REFERENCES, SELECT, and UPDATE.

So in theory you have executed these commands.

GRANT DELETE ON tablename to Users;
GRANT INSERT ON tablename to Users;
GRANT UPDATE ON tablename to Users;
GRANT SELECT ON tablename to Users;
GRANT REFERENCES ON tablename to Users;

Best to execute them separately in the future & avoid using deprecated statements.

| improve this answer | |
  • i only want to grant user to be login in and to be known or reference from the database table. Which permission then should allow this? Select only? – eNtsa2019 Mkontwana Jan 22 at 8:12
  • What issues are you having? What do you mean to be login? What have you tested? If the user has to only read from the table then select should be fine. – Randi Vertongen Jan 22 at 8:15
  • Ok basically, on my VS i am developing UI allow user to login or register. The authConfig.cs does not allow login to launch. that is why i had performed this database permission and still not coming write here. System.Data.SqlClient.SqlException: 'Login failed for user ''.' – eNtsa2019 Mkontwana Jan 22 at 8:17
  • @eNtsa2019Mkontwana Alright, what is the error message when you try to connect? Do you still have the same error after trying the grant? – Randi Vertongen Jan 22 at 8:18
  • 1
    @eNtsa2019Mkontwana obviously that is a totally different issue from the GRANT permission. Please post a new question for your login issue – Squirrel Jan 22 at 8:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.