I have three databases in an Azure SQL DB Managed Instance. I am using SSMS 18.4. One database I can right-click, choose Properties, and the dialog box comes up normally. The other two databases give me the following error.

enter image description here

I have spent a couple of hours Googling with no results. Anyone have any ideas?

1 Answer 1


Azure support pointed me to this article which worked to cure the problem. Apparently the issue was multiple old entries in the msdb backup sets. All left over from when I was experimenting with Azure SQL MI Migration Assistant. Interestingly, the database where the Properties dialog always worked also has multiple old entries in the backup sets. So it's still a head scratcher!

Revising this answer because the link above is dead, and I gave a more complete answer in this post on dba.stackexchange.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.