10

I have a brand new installation of SQL Server Reporting Services 2019 on top of MSSQL 2019 Enterprise CU1.

SSRS has been installed and configured using default settings, apart from the service account it should use.

Both AD and MSSQL instance are configured in minimum permissions only (or close to this state).

When I am accessing the Web Portal I receive an error saying "please try again later", which isn't much of help.

I found many similar posts asking for help on the same issue, but wanted to see the answer here.

0

4 Answers 4

11

After some digging I found plenty of unconnected issues, but finally managed to solve them and wanted to share them all in one place so nobody else waste that much time if hits the same issue (or some of them).

First you want to access is the Reporting Services Error Catalog, depending on your installation directory, it will be something like this:

?:\Program Files\Microsoft SQL Server Reporting Services\SSRS\LogFiles

As there will be multiple files I recommend you to stop the SSRS service (PS as admin):

Get-Service -Name SQLServerReportingServices | Stop-Service

Then remove all of the files there (still in the same PS session):

Remove-Item -Path ?:\Program Files\Microsoft SQL Server Reporting Services\SSRS\LogFiles -Force

This might fail for the ReportingServicesWMI_YYYY_MM_DD_HH_MM_SS.log file as it is in use, but there is no need to stop the WmiPrvSE.exe here, you can leave it as it is.

One you have your log space cleared you can start the SSRS service again:

Get-Service -Name SQLServerReportingServices | Start-Service

And access the Web Portal again. Go as deep as you need to access the error again and stop the SSRS service again. At this point you should be able to find your error message in one of the error log files.

As your can differ I will just list all of the fixes I had to apply:

  • Give Full Control to the service user I used to run reporting services over the:

    ?:\Program Files\Microsoft SQL Server Reporting Services\SSRS\ReportServer\RSTempFiles

  • Give SSRS MSSQL Login permission to View any database

    USE [master] GO GRANT VIEW ANY DATABASE TO [DOMAIN\SSRS_MSSQL_Login] AS [sa]

  • Allow Log on as a batch job to SSRS service user:

    RUN --> secpol.msc Security Settings --> Local Policies --> User Rights Assignment --> Log on as a batch job Add User or Group

Reference Material

1

I had the same issue today. Turns out it was an issue with one of the queries providing default values to a parameter. I found it by looking at the log files in C:\Program Files\Microsoft SQL Server Reporting Services\SSRS\LogFiles, specifically ReportingServicesService*.log.

Hope this helps someone!

Brian

0

Just as an addition, I'm a DBA and was getting the same error on one of the BI reports when I attempted to manage the report. It turns out that SSRS does not like single quotes in the report name. Customer 'CN' details.rdl I remove the single quotes and redeployed the report. That resolved the issue. Cheers

0

If the SSRS log says '401 unauthorized error' then perform the instructions given below.

  1. Add a new DWORD value in the registry path HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters

    Value name: DisableStrictNameChecking

    Data type: REG_DWORD

    Base: Decimal

    Value: 1

  2. Add a new Multi-String value in the registry path HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0

    Value name: BackConnectionHostNames

    Data type: Multi-String

    Value: mention the FQDN of your SSRS like SSRS.it.internal

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.