0

Every time I start a mongodb shell, I get this annoying warning:

Server has startup warnings:
2020-02-01T08:54:27.220+0100 I  STORAGE  [initandlisten]
2020-02-01T08:54:27.220+0100 I  STORAGE  [initandlisten] ** WARNING: Using the XFS filesystem is strongly recommended with the WiredTiger storage engine
2020-02-01T08:54:27.220+0100 I  STORAGE  [initandlisten] **          See http://dochub.mongodb.org/core/prodnotes-filesystem

I understand that in some environments, this is useful. But in my particular case, I'm using mongodb on a VPS server that has pre-installed ext4 filesystem. There is no option to change that. And it is not needed anyway - in this particular application, there are no performance problems and there will never be. The server is already overpowered for this application.

I was going through the documentation to find a command line option for suppressing this warning message, but there is none. Or maybe there is, but I couldn't find it?

2

To permanently suppress this server warning you currently need to use the XFS filesystem. The warning was added due to observed stalls with EXT4 during WiredTiger checkpoints.

You may want to upvote & watch SERVER-19790: Provide mechanism to clear/acknowledge startup warnings in the MongoDB issue tracker.

If you want to suppress displaying this warning (and all other startup warnings), start your mongo shell session with --quiet.

The quiet option is typically only used for non-interactive scripts as otherwise you may miss an important warning. Startup warnings only appear once per mongo shell session and highlight potentially serious issues like having access control disabled (or in your case, a filesystem which can result in stalls during checkpoints).

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.