1

I'm a programming student and I just started learning databases in college. However, everytime I try connecting to my databse in Oracle SQL Developer I have this message:

ORA-12505, TNS:listener does not currently know of SID given in connect descriptor.

After posting here, we came to the conclusion that the databse wasn't properly started. When I try to start it from the cmd I get those errors:

When I type "startup" in the SQL command prompt

ORA-01078: failure in processing system parameters ORA-00600: internal error code, arguments: [kspifisp:ksfdread_resilver], [0x000A9F388], [0x000A9F000], [512], [], [], [], [], [], [], [], []

When I type "select instance_name, status from v$instance;" in the SQL command prompt

ERROR at line 1: ORA-01034: ORACLE not available Process ID: 0 Session ID: 0 Serial number: 0

I've seen that I could go into the net manager in "Programs > Oracle - HOME_NAME" but I don't have this in my programs list. Of course I tried uninstalling and reinstalling the database several times.

I've done the same installation on my PC at home and everything works fine I just need to make it work on my school laptop. I'm currently on Windows 10 installed on a Macbook. The database I installed is Oracle Database Express Edition (XE) Release 11.2.0.2.0 (11gR2).

Here is the 'init.XE.ora' file

SPFILE='C:\oraclexe\app\oracle\product\11.2.0\server\dbs/spfileXE.ora' 
  • 1
    Win 10 on a mackbook? Is that running as a VM? (I have no experience with Mac). OK, we need to see the contents of C:\oraclexe\app\oracle\product\11.2.0\server\dbs/spfileXE.ora. It is actually a binary file, but most of it (and the part we are interested in) is clear text. Don't mess with it directly. Make a copy, then open the copy in a text editor and copy and paste the clear text. Also, we'd want to see the contents of 'alert_XE.log'. Probably located at c:\oraclexe\app\oracle\diag\rdbms\xe\xe\trace. Edit your original post to include these items. – EdStevens Feb 5 at 13:52
  • 2
    I suggest you skip all of this - running windows as a vm on your macbook is making this harder, not easier. Just go get this VirtualBox VM, it's already setup and ready to go, you simply import to VirtualBox (free download/install), and hit 'start' oracle.com/database/technologies/databaseappdev-vm.html – thatjeffsmith Feb 5 at 13:56
  • I added the spfile and the alert_XE.log in the original post. And Jeff, does it make it harder even if I have a Windows partition? I've done C# and multiple Windows oriented things on my Macbook and it never caused any trouble – Joe Rouleau Feb 5 at 14:01
  • Hi Joe and welcome to the forum! :-) When replying to comments, it's best to reply to them one at a time and put the @ symbol in front of the person's handle to let them know that you've replied, if, for example, you've added some requested information or whatnot. I.e. to let me know that you've read this comment and found it awe-inspiring ( ;-) ) - you'd put @Vérace (note: no space) into the comment text. HTH... – Vérace Feb 5 at 15:00
  • @Vérace oh right sorry for that! Thank you for the tip :-) – Joe Rouleau Feb 5 at 21:50
0

If you are running XE on windows the folder delimiters have to be consistent Instead of

SPFILE='C:\oraclexe\app\oracle\product\11.2.0\server\dbs/spfileXE.ora'

Use

SPFILE='C:\oraclexe\app\oracle\product\11.2.0\server\dbs\spfileXE.ora'

The best suggestion is from thatJeffSmith. Use the prebuilt VM's from Oracle in their VM product Virtual Box

Also you can see if your Oracle is successfully installed by finding services.msc and looking for a windows service with Oracle in the name. There should be a listener and a database service. The database service has to be running before you can connect from your windows vm and the listener has to be up to connect from other devices.

| improve this answer | |
  • 2
    Right thank you! I tried installing the 18c instead of the 11g that the teacher wanted us to use and it solved the issue. With the 18c I have the met manager so I messed with that and made it work! Another teacher tried to figure it out with me and noticed that my databases were installing in a subfolder that the other students didn't have. Maybe that my computer didn't take that subfolder into account we'll never know. At least it's working now :-) – Joe Rouleau Feb 5 at 21:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.