I have an issue with an SSIS package, that when deployed via VS2017 to the integration services catalog is not actually being deployed. This is an individual package deployment, and not a project deployment. There are no error messages, and the deployment appears to go through fine. Checking the initial packages and projects tables indicates that although the deployment has happened (project timestamp gets updated), the latest version of the package code has not really been deployed as the version number on the packages table does not match the latest version from within Visual Studio.

In fact, the issue is exactly as described in this previous post by another member, only there was no update on the resolution on that post. I'm hoping that someone else may have come across this situation.

Why is my SSIS package not getting updated?

Some additional information that may assist:

Right click, Project deployment - this works (we've tried this with another project, although for the project we're really interested in we cannot do that as not all the packages are ready for deployment at a project level).

Right click, Package deployment - this doesn't work (deployment is reported as a success, but evidently the package has not been deployed).

Calling the ISDeploymentWizard from the command line for the package in question doesn't work either. Again, no errors reported, but nothing deployed.

When using the wizard via Visual Studio, the XML you can save post-deployment reports 'success' at all stages.

Thank you.

  • @Mr.Brownstone - regarding your original post, did you discover any workaround at all?
    – SteveG
    Feb 14, 2020 at 7:45
  • I think this is also a similar question, it may help
    – Hadi
    Feb 16, 2020 at 21:43
  • Hi @SteveG, on the project properties, is the "TargetServerVersion" set to SQL Server 2017? have you tried to "Rebuild" (right-click/rebuild) the project before deploying?
    – Evandro
    Feb 18, 2020 at 15:25
  • Thanks @EvandroMuchinski for the suggestions. I can confirm that the TargetServerVersion is set to "SQL Server 2017", and that rebuilding the project has no effect.
    – SteveG
    Feb 18, 2020 at 16:18
  • It might be worth trying to upgrade to VS 2019.
    – dev_etter
    Mar 3, 2020 at 20:02

1 Answer 1


Package deployment model has nothing to do with SSISDB. Instead when Package deployment model deploys to SQL Server it ends up in the msdb database in the sysssispackages table. Follow these instructions to view deployed packages. Or you can query that table.

  • 1
    Since SQL Server 2016, using ProjectDeploymentModel, after the initial deploy you have the option to deploy only a package if you wish to. It creates a new version f the project, but the deployment footprint if smaller.
    – Evandro
    Feb 19, 2020 at 9:39
  • @EvandroMuchinski agreed. And you may be right that this is what the op did? SteveG did you convert the project to Package deployment model? Or did you try to deploy one package within a Project deployment model project? Feb 19, 2020 at 12:23
  • Thanks for the responses. Project is set to ProjectDeploymentModel, and we are trying to deploy one package from within that project.
    – SteveG
    Feb 20, 2020 at 8:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.