0

For several years now I have used the MariaDB Audit Plugin on my MySQL databases.

I am now looking to start Upgrading my databases to MySQL 8, and so have just tried installing it onto MySQL 8.0.19, but am getting the following error:

Error Code: 1126. Can't open shared library '/usr/lib/mysql/plugin/server_audit.so' (errno: 2 /usr/lib/mysql/plugin/server_audit.so: undefined symbol: fn_format)

I tried downloading the latest version (audit 1.4.7 from the MariaDB 10.4.7 binaries) but it made no difference. Downloading older versions of the plugin also made no difference.

Is this likely to be a MySQL problem or a Mariadb problem? And is there a way to get round this. Most of my databases are installed on Debian 9 or 10 servers.

0

It's not really an answer, but I found a workaround, which is to use the Percona Audit Plugin instead (which I used to use anyway, but stopped working when I moved from 5.5 to to 5.7, but strangely now works again with 8.0). In my case I already have the support code and infrastructure to switch back to this so it's not a big task.

| improve this answer | |
0

MariaDB used to be a drop-in replacement for MySQL, so their libraries used to be compatible. This is no longer the case:

MariaDB and MySQL are growing apart and becoming increasingly more different, unfortunately, which means that incompatibilities in libraries like you have found are becoming ever more likely. I don't think MariaDB makes an effort to stay compatible with MySQL versions from 8.0 onwards.

A work-around would of course be to upgrade your database to MariaDB 10.5 instead of MySQL 8.0.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.