0

I installed wamp server on my PC and by default wamp server is connected to MariaDB as showed below

enter image description here

How can i switch to MySQL? Thank you in advance for your help.

6

To pick MySQL or MariaDB, right click on the wampmanager icon in the system tray and you should see this this menu

enter image description here

Please Select Components like I did please check the 2nd Screenshot

enter image description here

1
  • at the time of setup/installation you will see the 2nd screenshot.
    – Arpit Jain
    Apr 17 '20 at 9:22
0

You must click on WAMP icon and go to MySql and from list select "Use a port other than (your port)" and set your port To "3306". Ok your default DB is Mysql and has green check.

0

The -to my knowledge- only way to solve the luck of MySQL databases in WAMP is to uninstal it and reinstall making sure to have MySQL selected when you are prompted what to instal.

Do not worry, your WAMP website/webapp files (or whatever you are developing) will not be harmed or lost in the process, unless you select them to be deleted.

Once the fresh installation is done, just move the contents from your previous wamp64\www folder in the new directory (if for example you had wamp installed in C:\wamp64 and now you installed WAMP in C:\wamp64_2 folder move the contents of www folder from C:\wamp64\www over to C:\wamp64_2\www) and you can load it all again.

One note, if you was using some databases in this your other projects you will need to move them using export and import via the phpMyAdmin or Adminer, but I find it unlikely, since the question seems like related to a luck of a specific DB type and I am guessing you are still in the first steps

0

I found the best way to solve this problem. we can download the add-ons for the mysql or mariaDB based on the requirements .During the process of installing be sure you are installing the right version of MYSQL

below is the link for downloading add-ons

https://wampserver.aviatechno.net/

After downloading just install it.

for changing to MYSQL just go to wampsettings and

  1. check the Allow MYSQL wampp restarts

  2. uncheck the Allow mariaDB

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy