0

I'm using Couchdb v3.0.0, and testing the browser GUI.

I have created users in the database "_users", and have also assigned a role to that user.

I have tested by getting related documents via curl or browser with that user on a particular database with no problems.

But if I want to login to the browser GUI with that user, it will just keep loading in the "databases" section. Choosing other sections will also be prompted "You are not a server admin" in 1 step or 2.

The above happens regardless if the tester account has been assigned member or admin access, neither of them can use the browser GUI to browser documents inside the database.

Is it true that the browser GUI is only usable by admins (which are defined in the local ini files)? or am I missing anything?

0

In CouchDB 3.0.0, the /_all_dbs endpoint became admin-only. This has the side-effect of Fauxton, the “Browser GUI”, not loading properly for non-admin users, as it starts out by reading /_all_dbs.

The release notes have a section that go into the changes.

This is the code change: https://github.com/apache/couchdb/issues/2576

You can get the previous behaviour by setting the config variable [chttpd] admin_only_all_dbs to false, but that allows even unauthenticated users to get a full list of your databases.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.