1

I am trying to restore a database dump from a file for an online SQL course I'm taking into DBeaver. When I restore it, however, it runs for a little bit and then I get the error message

ERROR 1146 (42S02) at line 4037: Table 'acumatica.AUNotification' doesn't exist

I've tried:

  1. Manually dropping the table via the mysql command line, and then copying the CREATE TABLE statement from the .sql dump file to manually create it.

  2. Reinstalling SQL

  3. Using sqldump except I think it just dumped the existing file.

  4. Doing mysql -u root -p --database=acumatica < dump-acumaticadb-201903141403.sql

All of my attempts to restore it work for a little bit- when I refresh the database in DBeaver, it shows the table aunotification and all preceding tables. There are no subsequent tables. Also, I'm using the utf8mb4 charset, so I don't think that's the issue.

I would really appreciate any help someone could give- the other threads I've found online have not helped me.

Here's the full error message in DBeaver after restoring the database:

/usr/bin/mysql --host=localhost --port=3306 -u root acumatica
Task 'MySQL script' started at Sun Mar 22 11:43:56 PDT 2020
ERROR 1146 (42S02) at line 4037: Table 'acumatica.AUNotification' doesn't exist
Task 'MySQL script' finished at Sun Mar 22 11:44:01 PDT 2020
2020-03-22 11:44:01.556 - IO error: Process failed (exit code = 1). See error log.
2020-03-22 11:44:01.557 - java.io.IOException: Process failed (exit code = 1). See error log.
    at org.jkiss.dbeaver.tasks.nativetool.AbstractNativeToolHandler.executeProcess(AbstractNativeToolHandler.java:182)
    at org.jkiss.dbeaver.tasks.nativetool.AbstractNativeToolHandler.doExecute(AbstractNativeToolHandler.java:237)
    at org.jkiss.dbeaver.tasks.nativetool.AbstractNativeToolHandler.lambda$0(AbstractNativeToolHandler.java:52)
    at org.jkiss.dbeaver.runtime.RunnableContextDelegate.lambda$0(RunnableContextDelegate.java:39)
    at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122)

https://i.stack.imgur.com/6KNh1.jpg error log screenshot

https://pastebin.com/KfCRW2G2 create statements and surrounding file

6
  • Does it show the table 'aunotification' or the table 'AUNotification'? Mar 22, 2020 at 19:57
  • @GerardH.Pille Yes- the dbeaver Tables folder for the acumatica database shows 'aunotification' at the bottom of the list. It is the last table present. Mar 22, 2020 at 19:59
  • The error log and the create table statement would have allowed something more than wild guesses. Mar 22, 2020 at 20:02
  • Question has been closed as "off-topic". When I read what's "on-topic", the first line says: "Database Administration including configuration and backup / restore". It would have been interesting to find out why the results of a mysqldump cannot be restored. Mar 24, 2020 at 12:02
  • On what OS was the dump created? Mar 24, 2020 at 12:03

1 Answer 1

0

The create table may not have used quotes around the table name, while a reference to it does.

Unless lower_case_table_names=1 is set upon database creation, the case of the tablenames has to be respected when quoted.

12
  • All references (from my quick skim of the error line area) to aunotification in the dump file are surrounded with backticks Mar 22, 2020 at 20:08
  • But what about the create statement? And do they use the same case? Mar 22, 2020 at 20:11
  • The create statement was fine! There were some references later within /*! statements that used AUNotification instead of aunotification. I replaced them with lower case instances and it worked- those tables were created. However, the error reappears some 500 lines later. Since this file is way more than 4000 lines long (which I'm very sure it is), how would I automate the process to fix these instances of unmatched case for table names? And thank you so much for responding, I'm really grateful. Mar 22, 2020 at 20:21
  • An editor like vim would do the job in a couple of seconds. Line editors too. Do you have experience with any of those? What is your OS? Did the create statement contain quotes? Mar 22, 2020 at 20:37
  • I'm on Ubuntu. I'm relatively inexperienced with vim, although I've read some introductory material- how could I make it so that all the different words change to lowercase? For example, I'm now experiencing my issue with the table EPLoginType, which is of course a different string than AUNotification. This is ocurring several thousands of lines of code away from my initial problem. The create statements contain backticks for the table names. Mar 22, 2020 at 20:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.