1

I'm trying to login to a SQL server on my work network with a VPN connection to the network and by using my AD credentials. When I'm directly on my office machine, I use "Windows Authentication" as the Authentication method in SSMS and that works fine.

When I'm VPN'ed onto the network and using my local machine, Windows Authentication doesn't work (understandably) but if I try to use the "Active Directory - Password" Authentication method (I was hoping I could put in my work's AD account to connect to the remote server) I get the following error:

SSMS Login Error

It sounds like it can't find the server, but when I ping the server from my local machine, I'm getting a response.

Note: "Allow remote connections to this server" is checked.

  • I am confuse by several things here. Are you trying to RDP to the server, or are you trying to connect to SQL on the server with SSMS? – James Jenkins Mar 24 at 15:31
  • @JamesJenkins No RDP, just directly connect to the SQL Server with SSMS on my local machine (while on a VPN connection to the office network.) – J.D. Mar 24 at 15:40
1

As I said in my comment, I do not fully understand what your issues are.

But I think the solution is to open SSMS as another user.

Personally I have the SSMS icon in my task bar:.

  • Shit + R click
  • Select "Run as a different user"
  • Enter the account and password you would normally use on your office machine.

SSMS will connect to instances as if you where on your office machine and had opened SSMS.

Note I assume you are working remote for possibly the first time. There are a number of security barriers, that your organization may have in place to prevent you from connecting from home. I can't address those, and this is probably not the site to address them.

  • When I Shift + R + left-click the icon in my task bar, it just opens up an instance of SSMS as per usual, without prompting any options. – J.D. Mar 24 at 15:43
  • Never mind, I found I have to right click the icon first, then Shift + R + Right-click the "Microsoft SQL Server Management Studio" button in the flyout menu. I found it, thanks. – J.D. Mar 24 at 15:44
  • Also, I just realized you were saying R click for right click, my mistake. Shift + Right-Click is all that's needed lol. – J.D. Mar 24 at 15:48
  • 1
    @J.D. I use run as a different user, all the time. Based on your last comment here, you figured out how to do it correctly. I think your problem is security related not SQL related and I can not help you at all with it. :( – James Jenkins Mar 24 at 15:57
  • 1
    Thanks, I'm going to vote up your answer since it at least helps me better establish the issue I'm encountering and points me in the right direction, appreciate it. – J.D. Mar 24 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.