0

I have a db for which I am getting error as shown below.

The Filegroup «PRIMARY» for the database "CRM" in SQL instance "MSSQLSERVER" on computer "prod" is running out of space.

sqace details in MB are as below: mdf file now has reached 249 GB.

CRM mscrm D:\Program Files\Microsoft SQL Server\MSSQL10_50.MSSQLSERVER\MSSQL\DATA\CRM.mdf 249157 CRM mscrm_log E:\Program Files\Microsoft SQL Server\MSSQL10_50.MSSQLSERVER\MSSQL\Data\CRM_log.LDF 5137

D and D drives are having more than 50 GB free space. C and temp has more than 30 GB and 20 GB free space each .. No drive is running out of space.

growth is set as auto with no restriction at this database.

Any clues ?

Thanks Hungry DBA

1

This isn't an error from your SQL Server. At least I couldn't find it in sys.messages. (If you didn't post the exact error message or if you have an additional error number, please adjust your post.)

You have some monitoring software which assumes that you want to get notified when a database is close to full (for some filegroup). You can choose to ignore that notification and rely on the autogrow functionality in SQL Server, or you can expend the size of the file manually. Up to you.

Manually growing can be better since you control when you do this. Not that growing a file block general operations, but if you wait for an autogrow to kick in, then you have one or more users that suffers during that autogrow (those who need more space at that point in time).

Also, make sure that you have reasonable autogrow settings and consider whether you want to turn on Instant File Initialization.

| improve this answer | |
  • Thanks Tibor for your comments !!! This notification came from the sql monitoring software SCOM and is as below: "The Filegroup «PRIMARY» for the database "CRM" in SQL instance "MSSQLSERVER" on computer "prod" is running out of space." Do we need to do any actions ? The sql statements running at this database are reporting to be too slow. Cheers Hungry DBA – Hungry DBA Apr 9 at 13:34
  • Ok, that doesn't change anything for my comment. It still applies. If you don't want to grow manually in advance, then adjust the alert. Slowness is probably unrelated. But, sure, go ahead and grow manually and see if it affects the slowness. – Tibor Karaszi Apr 9 at 20:05
0

If your file growth is set to unlimited and you have plenty of free disk space (50GB is not a lot on some systems, but your system is quite small) then the issue is with your SCOM alert. So the alert is probably using DMVs to calculate percentage of file/filegroup remaining without taking into account the free disk space.

First stop is to tune your alert so that it calculates the remaining file space based on the maximum size the file is able to grow to and not its current size.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.