0

I have one master and 2 slaves,one is replicating but another slave which is read-only not replicating.

From Master :

show master status; +------------------+----------+--------------+------------------+-----------------------------------------------------------------------------------------------------+ | File | Position | Binlog_Do_DB | Binlog_Ignore_DB | | +------------------+----------+--------------+------------------+-----------------------------------------------------------------------------------------------------+ | mysql-bin.002490 | 13000479 | | | +------------------------------------------------------------------------------

Slave : Master has sent all binlog to slave; waiting for more updates

Slave status:

Slave_IO_State: Waiting for master to send event
     Master_Host: ....
              Master_User: repl
              Master_Port: 3306
            Connect_Retry: 60
          Master_Log_File: mysql-bin.002490
      Read_Master_Log_Pos: 13106512
           Relay_Log_File: mysql-relay-bin.000018
            Relay_Log_Pos: 13106725
    Relay_Master_Log_File: mysql-bin.002490
         Slave_IO_Running: Yes
        Slave_SQL_Running: Yes
               Last_Errno: 0
               Last_Error: 
             Skip_Counter: 0
      Exec_Master_Log_Pos: 13106512
          Relay_Log_Space: 13107019
          Until_Condition: None
           Until_Log_File: 
            Until_Log_Pos: 0
       Master_SSL_Allowed: No
    Seconds_Behind_Master: 0
  Slave_SQL_Running_State: Slave has read all relay log; waiting for more updates

slave processlist show below for system user

i. Waiting for master to send event
ii.Slave has read all relay log; waiting for more updates

Still not replicating.what i have to check ?

Any suggestions.

Thanks in advance.

  • Look like everything is fine. Why do you think there is still no replication? – Kondybas Apr 22 at 13:06
  • Everything seems to be fine. Try onething to ensure replication is running that create one table on master & check same on both slave – JYOTI RAJAI Apr 22 at 13:21
  • I have created database on master but not replicating, tried 3/4 times. – Ch.Umakanth Apr 22 at 15:23
  • Replication not happening on above slave (details given in question) and in other slave replication happening. – Ch.Umakanth Apr 22 at 15:31
  • If slaves behave differently then they differently configured. – Kondybas Apr 22 at 19:12
0

These say that it is replicating:

     Slave_IO_Running: Yes
    Slave_SQL_Running: Yes
           Last_Errno: 0
           Last_Error: 

Seconds_Behind_Master: 0

Check my.cnf on both the Master and Slave -- look for replicate/binlog_do/ignore_... Perhaps you are not allowing some databases or tables to go from (do) the Master or be received by (ignore) the Slave.

The various %read_only variables control whether or not you can connect to the server and write; replicated writes are always allowed on the Slave.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.