1

Platforms:

  • Windows Server 2016
  • SQL Server 2016
  • SSMS 2018

Problem:

enter image description here

Create failed for Availability Group listener 'lsn'.

None of the IP addresses configured for the availability group listener can be hosted by the server 'MACHINE1'. Either configure a public cluster network on which one of the specified IP addresses can be hosted, or add another listener IP address which can be hosted on a public cluster network for this server.

I have three machines:

  • the first machine runs Active Directory
  • the second machine is named MACHINE1
  • the third machine is named MACHINE2.

The machines are nodes for SQL Server.

My machines, user and cluster are added to Active directory in a OU and they have necessary permissions. IPv4 configuration is complete as well.

My Active Directory looks like this:

enter image description here

  • cluster1 - Failover cluster virtual network name account
  • MACHINE1
  • MACHINE2

I couldn't find any clear solution for this problem.

1

In order for the IP address to be brought online, three requirements must be met (among others, but these are the most relevant to this error):

  • At least on of the listener IP addresses must be in the same subnet as one of the cluster networks.
  • The cluster network that is in the same subnet as the listener IP address must be configured as a public network (will add more details in a few minutes).
  • The IP address must not be in use on the network.

You can view and configure the cluster networks in Failover Cluster Manager. Expand the cluster and select the Networks node to see the networks. Right-click on a network and select properties. Ensure that "Allow clients to connect through this network" is enabled on all networks that are used by listener IP addresses.

If you need further help, please add more detail to the question regarding the network and IP configuration of the nodes and the listener. The only useful information in your question at this point is the error message, so that's all I have to go on.

| improve this answer | |
  • Hi sir, I checked my Failover Cluster Manager and it enabled. My addresses are: 192.168.3.1 (active directory), 192.168.3.2 (node1), 192.168.3.3 (node2) and my subnet is (192.168.3.0/24) for cluster network. And my cluster's ip is 192.168.3.8. So I'm trying to give 192.16.8.3.8 for listener while I configuration to AO. My nodes' dns are configured like my active directory machine's ip. Gateway ip is 192.168.3.10 for all and subnet mask is 255.255.255.0 for all machines. – jrdba May 1 at 17:05
  • 1
    You can't use the same IP address for the cluster IP and the listener. – Tony Hinkle May 1 at 18:04
  • Syntax error. Cluster is 192.168.3.9, and listener 192.168.3.8. – jrdba May 1 at 18:06
  • The only other thing I can think of is that 192.168.3.8 is already in use on the network. I don't know what else would cause this error. – Tony Hinkle May 1 at 18:09
  • I tried .20, .55, ... but it doesn't work... – jrdba May 1 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.