0

I'm new to Reporting Services. We have SSRS 2017 set up on a Windows Server 2019 Standard box.

I've got my report all written and tested but given the size of the output, I'm trying the subscription option to write the output to a local file, but so far I've run into nothing but problems.

I'm trying to write to \\localhost\ReportOutput as a share. I've granted full control on that folder to all the accounts I've tried to use.

First problem - whenever I've tried the * Use The Following Windows user Credentials option, I can type in the creds, but when I click Apply, it blanks out the password. When I re-edit the subscription I get warning/errors that those fields can't be blank. The username is not blank (though it gets the warning anyway); the password is blank.

Second problem - no matter what creds I enter, I get "The permissions granted to user '' are insufficient for performing this operation." as an error when the report is run. '' is not trying to hide my creds - that's really what the error says.

Third problem - I've tried configuring the system wide Subscription Settings File Share Account and configuring the subscription to use that instead. When I run the report, I get the same "permissions granted" error above. I've tried using both domain and local users in this setting.

When I look at the log file, I see these error messages consistently before the insufficient privs error:

Reporting Services account may not possess permission to perform authentication checks.
Check the Windows Authz documentation for more information and details on diagnosing issues.

I've done a lot of googling trying to find what to do about it, but most of the results associate it with email delivery failures (which we are not having), and some of the suggestions (like granting a user 100% read privs in the domain controller) are things I don't have the ability to use.

Has anyone else had so much trouble with SSRS outputting results to a file?

Thanks

0

Turns out that the report tries to run as the Owner of the subscription, and that credential needs to have a higher level of privs in the AD for the save-to-file-share option.

I don't have those privs but I can tell SSRS that the subscription is owned by someone that does.

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.