0

I have a Jira 6.4.7 instance running on MySQL 5.6.44. I'm in the progress of updating the Jira instance to 7.0.5, which still supports MySQL 5.6.

I accidentally hooked up a newer Jira 7.0.5 to the same database, wich inserted performance_schema tables. Jira 7.0.5 probably thought it was running with >= mysql 5.7.

I immediately stopped the Jira 7.0.5 instance, but the references to performance_schema are still there.

When I look at the database with MySQL Workbench, I get this error:

Error Code: 1146 Table 'performance_schema.user_variables_by_thread' doesn't exist

Everything still seems to work with jira 6.4.7, but I can't dump the database anymore to move it somewhere else.

I've tried using the xml export and import from jira, but this copies the error from the database.

I've tried

[mysqld]
performance_schema=OFF

but the error persists.

I couldn't find the performance_schema table in other MySQL databases, because then I could have copied the table.

So how can I fix this? Can anyone provide an SQL statement of how this table should look like? Or how can I find and delete the references to performance_schema in my current MySQL 5.6 database?.

  • 1
    what workbench version? It could be that workbench is looking for the perf schema table, not JIRA. ref this answer – danblack Jun 23 at 8:19
  • 8.0.16 - you were right, thanks for the hint. – mles Jun 25 at 11:18
2

performance_schema.user_variables_by_thread is in MySQL-5.7 but not MySQL-5.6. It cannot be copied as its generated by the server to represent the internal state.

MySQL-5.6 seems to have deprecated Jira support per https://confluence.atlassian.com/adminjiraserver/supported-platforms-938846830.html

MySQL-5.7 reference on user_variables_by_thread

| improve this answer | |
  • Oh ok not in mysql 5.6. I've updated my question. – mles Jun 23 at 8:01
0

The issue was using MySQLWorkbench 8.0.16 and mysqldump 8.0.19 which are both looking for performance_schema tables in MySQL 5.6, which only exist starting with MySQL 5.7. Updating MySQLWorkbench to 8.0.20 and using mysqldump with the flag --column-statistics=0 made the errors go away.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.