Whenever I attempt to submit a query to Azure Synapse SQLDB (or try to do anything with the database from my application called DBForge) I get the following error message:

USE statement is not supported to switch between databases

Can someone let me know how to overcome this issue?

1 Answer 1


If you check out the documentation for the USE statement, you'll see that it is not supported for Azure Synapse Analytics (formerly Azure SQL DW).

To change database contexts, you'll have to open an explicit connection to the desired database.

If you're having issues with your IDE, try specifying the desired database in your connection string when you connect so there is no switching required.

  • thanks for reaching out. I've taken a brief look at the link you provided and it looks promising. I have also submitted a support ticket to dbForge
    – Carltonp
    Jun 23, 2020 at 19:48
  • How @LowlyDBA, I tried the suggestion in the link you provided, but I'm still getting the same error
    – Carltonp
    Jun 24, 2020 at 20:23
  • @Carltonp edit your question and add what your connection looks like, as well as the command you're trying to execture Jun 24, 2020 at 20:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.