4

I am trying to a restore a SQL Server from a .bak file and always get the same error :

The database was backed up on a server running version 15.00.2000. That version is incompatible with this server, which is running version 15.00.2000.

I have already seen the issue in Stackoverflow but I'm struggling because the versions here are the same ..

I am using SSMS and I already tried restoring to a SQL Server 2017, to the latest Cumulative update of SQL Server 2019 and to the first SP of SQL Server 2019. Wondering if I am missing something (configuration, code, ..) in SSMS to make it work.

3
  • 2
    Possibly related: blog.sqlauthority.com/2020/01/03/… Are you using Azure Managed Instances?
    – Doug Deden
    Jul 27, 2020 at 16:45
  • 2
    Yeah, if backup was on Managed Instance, it cannot be restored to on-prem. BACKPAC is what is supported going from MI to on-prem. Jul 27, 2020 at 17:57
  • You are correct that you cannot restore from Managed Instance to an on-prem version, but I think MI's still report their version as 12.0.20000; although they support just about every 2019 feature. Jul 28, 2020 at 12:24

1 Answer 1

2

Restoring it on SQL MI rather than Azure SQL DB or SQL Server worked perfectly

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.