0

In SSMS (versions 17 and 18), IntelliSense is not working with the sa user, but it is working with another user.

If I connect to a SQL database with the sa user and create a query window, IntelliSense does not work in this window. However, if I make a second connection to the same database with another user and create a query window, IntelliSense works. If change back to the query window with sa user, IntelliSense again does not work. IntelliSense AutoComplete

2
  • 2
    Does this answer your question? IntelliSense not working but it is enabled Aug 4 '20 at 15:15
  • A Linked Server and a Synonym have been declared, which was included in a view and the connection to LinkedServer has been lost. LinkedServer and Synonym were deleted and re-created. Question closed.
    – KostasM
    Aug 7 '20 at 6:32
0

When you create a user in sql, it is generally assigned the default bd you want to work with, that's why the IntelliSense works for you, although I think you shouldn't use the SA user for that, you can make the IntelliSense work by calling the bd with which you want to make inquiries ...

use [yourdb]
select * from yourtable

example

1
  • For sa user, intellisense worked fine until last week. sa is a db owner. The other user for whom intellisense works has limited rights.
    – KostasM
    Aug 5 '20 at 6:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.