1

Starting from some version (it's actually earlier than the documented 17.2), SSMS has the Performance Dashboard built in, so you don't have to download and install it separately. Great.

We have SQL Server 2016 Standard and we are using it with SSMS 2017.

The Performance Dashboard works as intended, except in one specific place.
The bars on the System CPU Utilization chart are clickable, and when clicked, show which SQL loads contributed to the specific bar. This does not work. Instead, the following page opens:

Error:
A data source instance has not been supplied for the data source 'CHECK_DEPENDENCIES'.


enter image description here

I searched extensively for this issue, and only found discussions about fixing the reporting component when developing desktop apps, but nothing in regard of SSMS.

Further experimenting showed that:

  • SSMS 2016 does not have this entire Performance Dashboard page at all ("Performance Dashboard" is both the name of the entire report suite, and of one of its reports that contains the chart in question). It has other reports in the Performance Dashboard suite, but not the "Performance Dashboard" report.
  • SSMS 2017 has the "Performance Dashboard" page. It shows the same problem with SQL Server 2016, and with SQL Server 2017 on another machine.
  • SSMS 2019 has the "Performance Dashboard" page. It shows the same problem with SQL Server 2016, and with SQL Server 2017 on another machine. We did not have SQL Server 2019 to test there as well.

How do I fix this built-in performance report so that I can see the CPU load detalisation?

6
  • 1
    check you regional settings and SQL user Language Dec 21 '20 at 6:06
  • En-GB on the server and on the client.
    – GSerg
    Dec 21 '20 at 6:56
  • It's unclear what SSMS version you are using since it has its own release cycles now and they are not referred to by year, but I just tried the report on v 18.7.1 and it worked fine. I believe the latest is v18.8 from earlier this month. Try the newest version and see if that works. Dec 21 '20 at 18:27
  • @LowlyDBA-JohnMcCall I'm using the latest available versions of each SSMS, which is currently 17.9.1 and 18.8. I don't agree that they cannot be referred to by the SQL Server year because, while you can use a newer SSMS for an older SQL Server for the database engine, you have to use the matching SSMS for Integration Services.
    – GSerg
    Dec 21 '20 at 20:06
  • @RamilZYakupov You seem to be right. When en-gb is selected in the Windows regional settings (Settings - Time and Language - Region - Regional Format), the reports do not work. Changing that to en-us makes them work. The language selected in the SSMS settings does not affect this. Obviously this is not a good solution because it requires changing a global setting to make a single application work.
    – GSerg
    Dec 21 '20 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.