-1

I tried following these instructions, but there's no HKEY_LOCAL_MACHINE folder in regedit

Setting oracle_home didn't seem to work

C:\Users\ellie>set ORACLE_HOME = C:\App\db_home\WINDOWS.X64_193000_db_home

C:\Users\ellie>set ORACLE_SID=CDB

C:\Users\ellie>set PATH=C:\App\db_home\WINDOWS.X64_193000_db_home\bin

C:\Users\ellie>cd oracle_home
The system cannot find the path specified.

C:\Users\ellie>oracle_home
'oracle_home' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\ellie>echo %ORACLE_HOME%
%ORACLE_HOME%

I have oracle 19c

4
  • 3
    set ORACLE_HOME=C:\App\db_home\WINDOWS.X64_193000_db_home and cd %ORACLE_HOME%, Also, it should be set PATH=%ORACLE_HOME%\bin;%PATH%. Aug 30, 2020 at 17:45
  • This worked, but now I have a really dumb question. When i closed cmd and opened it again after setting oracle_home, it no longer remembers that i set oracle_home to something. When i open cmd again and type in cd %ORACLE_HOME% it says The system cannot find the path specified.. Is that normal? Aug 30, 2020 at 17:52
  • When you set an enviornment variable inside a command session, it only applies to that instance of that command session. Close the session, and everyting associated with it goes away.
    – EdStevens
    Aug 30, 2020 at 21:15
  • 1
    When yiou say there is no hkey_local_machine in regedit, I've got to believe that either you don't know how/where to look, or you have really, really messed up your installation. Simply installing the oracle software per the Installation guide - simply running 'setup.exe' should create the necessary registry entries with no intervention on your part.
    – EdStevens
    Aug 30, 2020 at 23:49

1 Answer 1

1

Usually registry keys for Oracle home are registered at the time of installation, not sure why registry keys are missing.When you set variables from command prompt you're setting at session level not system wide. In order to make it permanent you need to set either user wide or system wide variables.

From elevated command prompt type sysdm.cpl go to advanced tab click Environment Variables at the bottom,click new either system or user variables ,enter ORACLE_HOME and browse to ORACLE_HOME directory

enter image description here

After that you need to add bin in ORACLE_HOME directory to path,in the same pop up window look for variable path(user or system),click edit --> new browse to bin directory.

After completing above steps,open another command prompt and check for ORACLE_HOME and executable commands in bin directory(sqlplus,impdp,rman etc)

C:\echo %ORACLE_HOME% -- this variable read from either registry entries or system/user variables

C:\where sqlplus -- from path variable

Not the answer you're looking for? Browse other questions tagged or ask your own question.