0

I'm new-ish to MLS and have been trying to add new python packages like  attrs  to the python but it hasn't been working.

Our set up is SQL Server 2017 with CU14 on Win 2016.

Python version is 3.5.2

The usual command I run is:  

pip install attrs

and I run this from the C:\Program Files\Microsoft SQL Server\MSSQL14.MSSQLSERVER\PYTHON_SERVICES\Scripts but nothing happens.....

it says "collecting attrs" then nothing.

When I look in the So I updated a dev VM to SQL Server 2017 CU22, and it installed Python 3.7 and tried same thing - it worked.

But this doesn't help me as we already have existing SQL Server 2017 servers with this package in it and the dude who originally set this up is gone, so any help appreciated.

All the installs are default, nothing special.

1
1

I worked it out, it seems the VM it was running in was too high VMware hardware level. When I dropped the hardware back to a lower version, it worked.

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.