0

I'm using mongodb 3.6.18 I'm running a cluster of 2 shards and 1 config replicaset.

I get this error when trying to set the compatibility version to 3.6:

global:PRIMARY> db.adminCommand( { setFeatureCompatibilityVersion: "3.6" } )
{
    "ok" : 0,
    "errmsg" : "expected entry { _id: \"son.service_state\", lastmodEpoch: ObjectId('5f743676f790314e2a02cfd3'), lastmod: new Date(4294967296), dropped: false, key: { data_center: 1 }, unique: false } in config.collections for son.service_state to have a UUID, but it did not",
    "code" : 1,
    "codeName" : "InternalError",
    "$gleStats" : {
        "lastOpTime" : {
            "ts" : Timestamp(1601465931, 1),
            "t" : NumberLong(1)
        },
        "electionId" : ObjectId("7fffffff0000000000000001")
    },
    "$configServerState" : {
        "opTime" : {
            "ts" : Timestamp(1601465922, 1),
            "t" : NumberLong(1)
        }
    }
}

Did anyone encounter this before? how can i fix this?

0

1 Answer 1

0

Since your deployment is a sharded cluster, I think you have to run the command from a mongos. - https://dba.stackexchange.com/users/197957

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.