Running a Mac. I installed Postgresql 9 many years ago and configured it to auto-start. Now I have upgraded to version 12 using brew, but on system restart version 9 server is still starting automatically. I don't know how to determine what is starting it, I don't see anything in my bash_profile and I don't see a feature in brew or pg_ctl that allows me to disable an auto-start configuration. I have no postgres files in /Library/LaunchAgents either. Thanks


2 Answers 2


In answer to Prevent PostgreSQL from running at startup on Super User:

ithinkiknowruby wrote:

cd /Library/LaunchDaemons/
sudo rm com.edb.launchd.postgresql-9.0.plist

As of October 2023, you can disable automatically starting a Postgres.app database in the UI by:

  1. Opening Postgres.app
  2. Click the database on the left hand side (if you have more than one, you need to do this for each one).
  3. Click Server Settings.
  4. Uncheck Automatically start server.

Screenshot demonstrating how to click Server Settings then unchecking Automatically start server on Postgres.app

The .plist was not there for me, at least for Postgres version 16.

You might also want to go into Login Items (what Ventura calls items that start on login) and turn off Postgres.app, so the actual app doesn't start either on boot if you don't want that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.