1

i installed dbachecks module in a server. but when i am trying to execute get-dbccheck, it is throwing the below error

Populating RepositorySourceLocation property for module Pester.
VERBOSE: Loading module from path 'C:\Program Files\WindowsPowerShell\Modules\Pester\5.0.4\Pester.psm1'.
[18:59:41][dbachecks.psm1] Failed to import suitable version - Do you have Version 4* installed ?
Get-DbcCheck : The 'Get-DbcCheck' command was found in the module 'dbachecks', but the module could not be loaded. For more information, run 'Import-Module dbachecks'.
At line:1 char:1
+ Get-DbcCheck
+ ~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (Get-DbcCheck:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CouldNotAutoloadMatchingModule

I have updated the pester and psframework modules to the latest, still i am unable to execute the commands.

Can someone help me in this.?

2
  • There is a Wiki page on Github, maybe you can post your Issue there.
    – McNets
    Oct 4, 2020 at 19:14
  • thanks Mcnets. I have posted the question there... Oct 4, 2020 at 22:47

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.