1

I'm running SSMS 2019 on my laptop, connecting to 2 different SQL Servers - 2008 R2 and a SQL 2016 machine. When I'm physically in the building where the servers reside, Intellisense works great. But on days when I'm working from home, connected through VPN, Intellisense is very spotty. Usually it completely fails to work at all, but every once in a while, it'll auto-fill a database name as I type, but never a table or field name. I've tried refreshing the local cache (CTRL+Shif+R), but that hasn't helped. Any ideas?

As requested below, here are the results of running Test-NetConnection "Emden" -port 1433 over VPN connecion:

PS C:\Users\cjm> Test-NetConnection "Emden" -port 1433


ComputerName     : Emden

RemoteAddress    : 192.168.10.56

RemotePort       : 1433

InterfaceAlias   : Ethernet 2

SourceAddress    : 192.168.11.46

TcpTestSucceeded : True
4
  • 2
    IntelliSense is very chatty, running a high volume of (usually) short queries. I suspect your connection over vpn is adding enough latency that it's disrupting IntelliSense. Could you try running Test-NetConnection "Yourserver" -port 1433 (assuming you're running on the default port) from the PowerShell prompt over your vpn connection and adding the results to you question? – AMtwo Oct 17 '20 at 0:20
  • I've added the results. Thanks for the feedback. – Chris Miller Oct 17 '20 at 15:04
  • There is no "SSMS 2019" but using the latest version always helps, if you aren't already. I've also found Azure Data Studio's intellisense to be a lot more reliable in many scenarios, if that is an option for you. – LowlyDBA - John M Nov 24 '20 at 14:20
  • 1
    And like it or not Azure Data Studio is now installed along with SSMS. – David Browne - Microsoft Nov 24 '20 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.