1

Would like to recover InnoDB data from a crashed server. The last backup indicated it was running MySQL server 5.1.69. When doing a recovery, the log files show that the current MySQL won't support ib* files from this far back.

I tried installing 5.1.69 from archives and compiling from sources, but no-go, rabbit hole of problems.

Does anyone know the latest version of MySQL to support 5.1.69 ib* files? Will try that as a last resort. If it doesn't work, will go with the latest backup and some auxiliary data to try to reconstruct as much as possible.

2

You should be able to load it with 5.5. As a general rule, next version up should always work. You should be able to run mysqldump from there, or run mysql_upgrade to keep it as is for 5.5. Then if you want to upgrade from there, you have to go up to 5.6 and run mysql_upgrade again. Repeat for 5.7 and 8.0 depending on how far you need to upgrade.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.