0

When using the MySQL installer, it says "Visual Studio version 2015, 2017 or 2019 must be installed".

I have installed Visual Studio 2019 and "MySQL for Visual Studio", but it still says, "the requirement is still failing".

I should point out that I installed the 32-bit version of MySQL for Visual Studio, because I couldn't find a 64-bit version. Is this relevant?

What would cause this and how do I fix it?

MySQL error message

Error message when you click on "check" after installing VisualStudio

1
  • maybe it is like the python extension, mysql doesn't like that i use 64 bit, but i am only guessing i also couldn't install it
    – nbk
    Oct 25 '20 at 22:13
2

I had this issue, and it turned out to be because I didn't have the .NET workload installed in Visual Studio. You need to either select it on installation, or re-run the installer, select 'modify', and then check it in the list of options.

I left the default set of sub-options ticked (right hand side of screenshot) - I would guess that everything but the first two are probably unnecessary but I haven't checked.

modifying workloads screen

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.