2

I'm getting a SQL Server error:

Execution fail against sql server. Sql error number: 1236. Error Message: A transport-level error has occurred when receiving results from the server. (provider: TCP Provider, error: 0 - The network connection was aborted by the local system.)

This occurs when I execute a stored procedure.

The stored procedure has worked well for some months. Some days ago, we moved the database to another server and get this error.

I use this proc in an ADF pine-line, and sometimes I get this error, not always but very often. I try to remote to the server and execute directly from SSMS but the error still happens.

I have tried to research in many forums, but there is no solution that fixed my case. How can I resolve this? Any idea? Thanks

6
  • 1
    Welcome to the DBA StackExchange forum. I understand you already researched many forums. Have you seen this post? Oct 30, 2020 at 10:58
  • Yes, I have. And no solution work for me. Oct 30, 2020 at 14:28
  • When you execute the procedure in SSMS, are you executing it on the local server it lives on or are you executing from another server that has to make a remote call to the procedure?
    – J.D.
    Oct 31, 2020 at 3:14
  • I executed it on the local server that it lives on. Nov 1, 2020 at 5:03
  • If this fails when run locally it's probably not a network issue. So the other possibility is that the session was aborted by the server, perhaps because of a severe error or crash. The SQL Server ERRORLOG should have more information. Nov 1, 2020 at 15:03

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.