1

i am trying to simply export BACPAC file from azure db to azure blob storage

as mentioned here : https://docs.microsoft.com/en-us/azure/azure-sql/database/database-export

but it is failed with error :

The Azure SQL Server firewall did not allow the operation to connect. To resolve this, please select the "Allow All Azure"checkbox in the Sql Server's configuration blade.

what's the cause of this error i am not sure, do you think i have to enable allow all azure service checkbox in azure db firewall? ( before i took backup and i was not doing this step)

also wanted to mention that both resource azure blob and azure db are in private virtual network.

also i am scared of this : https://www.fmsinc.com/microsoft-azure/sql-server/security.htm

Thanks,

3
  • 1
    "do you think i have to enable allow all azure service checkbox in azure db firewall"? That is exactly what the error states. Yes turning this on allows network access to everyone in Azure, but without a valid login/password, no one is getting in. Just turn it off when you're done. Why do you want to export a bacpac anyway? There are other ways to do it, i.e. attach a VM to your vnet and run the bacpac export from there. Then you don't need to open the firewall to all of Azure, you can just open it to your VM Dec 8 '20 at 13:27
  • If we enable allow all azure service, the list of the ip's used by the data center: microsoft.com/download/details.aspx?id=56519 may be allowed to connect to the sql. But as what @Nick.McDermaid without a valid login/password, no one is getting in.
    – Joseph Xu
    Dec 8 '20 at 13:37
  • can anyone of you please redirect a Microsoft link where it state to enable that option for bacpac file export ? creating VM is extra work and maintain it, we do not want to create vm for just db export.
    – carihep
    Dec 9 '20 at 9:56
1

you have to allow azure services and applications to connect to your database.

Take a look at the firewall rules in Azure sql database: https://docs.microsoft.com/en-us/azure/azure-sql/database/firewall-configure

You can eventually allow azure services to connect to your database in this way: enter image description here

You can disable this option after the export activity. Please, remember that this is not an option of export task but this is a firewall rule of your Azure SQL Database Server.

Consider the export task like an azure service against your database so you have to allow azure to connect as written here: https://docs.microsoft.com/en-us/azure/azure-sql/database/firewall-configure#connections-from-inside-azure

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.