0

I had a Full Text Index population going on for too much time and storage, so I decided to stop it, but the population didn't stop.

Notes:

  • Both index and catalog are created using the Full Text Indexing Wizard (right-click on table name > Full Text Index > Define Full-Text Index).
  • I reproduced the problem several times (and still can), and the following describes what I experienced with the different Track Changes options: automatic, manual, and no tracking.
  • Dropping the index and the catalog works without no problem.

Track Changes: Automatically

  1. I first tried to stop it using:

    Right-click on table > Full-Text Index > Stop Population
    

    Which popped up a success window, while actually the population continued (confirmed by executing one of the queries posted here, and exec sp_spaceused MyTable which constantly showed a growing storage usage).

  2. I then tried executing:

    ALTER FULLTEXT INDEX ON MyTable STOP POPULATION
    

    Which failed with the following error:

    Warning: Full-text auto propagation is on. Stop crawl request is ignored.
    

    Although it's only a "warning", the command was in fact ignored, and the population continued.

  3. I then tried another option:

    EXEC sp_fulltext_catalog 'MyFullTextCatalog', 'stop'
    

    Which resulted in the same warning.

Track Changes: Manually

I followed the exact three steps above, but the results were somewhat different:

  1. For step 1, I again got a success window, while population still continued.

  2. For step 2, I got an error:

    Invalid object name 'MyFullTextCatalog'.
    
  3. For step 3, I got a warning:

    Warning: The ongoing population is necessary to ensure an up-to-date index. If needed, stop change tracking first, and then deactivate the full-text index population.
    

Track Changes: None (success!)

I followed the exact three steps above, but now experienced success:

  1. For step 1, I got a success window, and the population actually stopped.

  2. For step 2 (after I recreated the index using the wizard), I got the same error as above:

    Invalid object name 'MyFullTextCatalog'.
    
  3. For step 3 (after I recreated the index using the wizard), I got a success message, and the population did stop.

Question
What's causing the warnings\errors which prevent population from stopping (well, at least for auto and manual tracking)?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.